PDA

View Full Version : ir sensor problem....please read this one :)



abhishek_sharma
01-09-2008, 09:42 PM
i hope somebody answers this :)
i have been tryin to make a line follower...have got thru everything including microcontroller nd motor driving but am havin a tricky time with the ir sensors.

i use a ir led sensor pair : problem is that detector senses ir light only if i place it directly above ir led....
when i keep them side by side horizontally, as it would have to be in the actual robot....and then place a white thick paper over the pair, i dont get any response.....the detector doesnt recognise ir light.

i hope you get my problem....please give in your responses as to why this could be happening nd if shud go ahead nd assemble the thing on pcb hoping tht it wud work in the actual robot :D !!

allbits
01-09-2008, 10:16 PM
There are lots of threads running on the same issue.
do a search in the forums.

btw,
Line follower? why IR?? DO NOT USE Infra red to SEE things seen better with visible light.

use LDR /Photo transistor..

whzahp
01-10-2008, 12:31 AM
I think yr IR emitter is not powerful enough and also u must connect the detector in reverse bias for better range...it also depends on the design of the detector ckt....

ice
01-10-2008, 07:53 AM
Post your circuit here. Also what whzahp said was right, connect the detector in reverse bia.

abhishek_sharma
01-10-2008, 06:13 PM
the detector is in reverse bias.....i have kept vltage across led less than 2v as suggested by some line follower makers....

please check the ckt
http://img341.imageshack.us/img341/4953/cktre2.th.jpg (http://img341.imageshack.us/my.php?image=cktre2.jpg)

tpsbpl
02-08-2008, 10:14 PM
whats the value of +v ??? :idea: if you r using 5v try 180ohm 0.5 watt resistance

rao
02-09-2008, 05:30 AM
keep a resistor in series as said by tps.. also dont keep them parallel..
keep them at an angle following the whole reflection concept.


rao

docel
02-13-2008, 03:47 AM
Is there ANY component connected to the O/p of the LM324??