PDA

View Full Version : GUI Software for USBasp compatible Programmers.



avinash_g
05-10-2009, 03:34 PM
Hello Friends, :D

I have recently written a GUI Software for driving USBasp compatible USB Programmers. It is much easier to use than the avrdude or avrdude-gui.

You can download it free of cost from here

http://extremeelectronics.co.in/avr-tutorials/gui-software-for-usbasp-based-usb-avr-programmers/

Screen Shots
http://www.extremeelectronics.co.in/avrtutorials/images/USB_AVR_Programmer1.jpg

a7400
05-10-2009, 09:32 PM
hey... nice work

havent tried it out... but yess... it was somethin that was needed... avr dude gui is a pain to use...

heres another one

http://www.khazama.com/project/programmer/

cheers

vikas
05-11-2009, 12:11 AM
Nice Work !

Keep It up !!!

avinash_g
05-11-2009, 08:04 AM
Hello All Friends,

Thanks for your response. I tried

http://www.khazama.com/project/programmer/

But it is crashing and closing on some errors with out any any proper messages to user.

Also when I am trying to verify the flash it is always crashing!

I have tried to keep mine as user friendly as possible.

I request all members of RI to please test the software with their USBasp programmers and give their response.


This is the first public release so their might be some bugs. :!:

asimov_18
05-31-2009, 09:09 AM
I tried your GUI software. there seem to be a strange problem with my hardware. The thing is that currently I use a GUI software PROGISP its a chinese software and it works well with the hardware but with both your software and khazama software the hardware is not detected? this seems strange as the hardware works very well with PROGISP..........ppl can also try progisp (google it out)

But what ever be it I liked the GUI feel of ur programmer neat and clean egronomically designed......:-)


asimov

avinash_g
05-31-2009, 11:17 AM
a small fix. On some PCs you need to delete the following files from Installation folder (like C:\Program Files\eXtreme Burner AVR\)



libusb0.dll
libusb0.sys


Please close the application before deleting files. You may also require a system restart.

A good news for Linux Lovers !!!
Yesterday I have successfully compiled the software on Fedora 10

Soon it will be available on Linux Platform Too !
:D

asimov_18
06-02-2009, 12:30 AM
Hi Avnish,
deleting the 2 files worked and the programmer started working but while verifying a written chip the software fails and a pop up message is shown. check the url : http://rohittkhanna.googlepages.com/usbavrprogrammer

asimov

avinash_g
06-02-2009, 08:25 AM
Hello,

I think the problem is MCU pls try repalcing it. Also check the connections.

Is the MCU detected ?

asimov_18
06-03-2009, 09:48 AM
Hi Avnish ,
I tried that every time I get the same message . yes the chip gets detected and the same chip also gets programmed with the other gui software...I am not really sure if ths could be a problem at my end the only thing I missed out of the circuit schematic was the 3.6V zenners but they were for the D and D- nothing to do with the protocol as such.
...



asimov

avinash_g
06-03-2009, 09:54 AM
This is strange ! I have tested the Software well and many peoples are using it with no problem.

:!:

Can u tell me which chip r u usin

rao
06-03-2009, 12:18 PM
Great job Avinash, cant wait to test the linux based software.

:D

Rao

asimov_18
06-03-2009, 11:56 PM
Hi i am primarily using atmega8/8L

asimov

avinash_g
12-20-2009, 07:39 PM
Hi Guys !!!

Finally Succeeded in porting eXtreme Burner - AVR for Linux Platform !!!


http://extremeelectronics.co.in/images/main2.png

http://extremeelectronics.co.in/images/write1.png

You can download and test it from here
http://extremeelectronics.co.in/software/BurnerAVR/xAVR.tar.gz

NOTE:
* You must be logged in as root to access the USB Port. So open terminal log in as root, then go to the folder where you have extracted the file, then type ./avrprog

*libusb-0.1.12-20.fc10 Must be installed

*GTK2 port of wxWidgets GUI library (wxGTK-2.8.9-1) Must be installed

*USE your OS's package manager to install the above components. Do NOT Install the "Development Files"

I request all pro Linux user to try it out and give their valuable response !
[/url]