PDA

View Full Version : Problem using comparator LM293



chaitanya_cr8
07-08-2010, 01:17 PM
Hi!!

I am currently building a comparator based line follower. I implemented the circuit on breadboard but I found that it isn't working. The inputs of the IC have been connected to pairs of photo resistors whereas output has been connected to the LED's (For testing; I will later connect it to the DC motors).

I can see the resistance changing on the multimeter but the brightness of the LED's doesn't change accordingly as expected.

I have checked and rechecked the circuit but found no errors; changed the comparator as well but to no avail.:(

Please help!!

chaitanya_cr8
07-08-2010, 01:59 PM
The potential difference across the 9V battery after it is connected to the circuit drops heavily to 1.5 V. Correct me if I am wrong but that reading suggests that it is a short circuit. Is this noraml for comparator LM293N ?
Please help!!!!!!!!

allbits
07-08-2010, 02:33 PM
Post the circuit. There must be a short circuit somewhere.

Or the LDR resistance might be a bit too low. Anyway post the circuit with all values.

chaitanya_cr8
07-08-2010, 11:48 PM
Here is the image of the circuit.
http://dc270.4shared.com/img/336496823/16f1b337/crct.jpg (http://www.4shared.com/photo/UVtrhFZS/circuit.html)

allbits
07-09-2010, 03:22 AM
cant make out anything from it. post the CIRCUIT DIAGRAM.

chaitanya_cr8
07-09-2010, 12:30 PM
here is the CIRCUIT DIAGRAM

extremely sorry for my bad paint skills

http://dc266.4shared.com/img/336887741/57e7bc0e/CRCTPAINT.JPG?rnd=0.08440466296746474 (http://www.4shared.com/photo/lVJiq7aV/CRCTPAINT.html)

all the LDR's show resistance 20K ohms in total darkness. Variableresistor is also of 20K ohms and is used for balancing.
Numbers beside the IC connections show the pin number with corresponding names in the datasheet.
1. Output A
2. Input A-
3. Input A+
4. GND
5. Input B-
6. Input B+
7. Output B
8. V+ 9V

chaitanya_cr8
07-09-2010, 12:36 PM
Hey I found one more thing. Whenever I disconnect the 9V supply to the IC, both the LED's glow and battery shows very little fall in the potential difference but as soon as I connect the 9V supply back to the IC, both of them get switched off and thus the p.d. fall upto 1.5V.


Btw thanks a lot allbits for listening and taking interest in my problem.

asimov_18
07-09-2010, 01:33 PM
Hi,
1) post the schematic with resistor values.
2) u r connecting the inverting and non inverting inputs of two comparators together(connecting pin 2 and 5 also connecting pin 6 and 3) , is that what u intend to do? shouldnt it be 2 and 6 connected together and 2 and 5 connected together?

3) use eagle cad or express pcb to draw schematic.

Asimov

chaitanya_cr8
07-09-2010, 03:20 PM
Variable resistor and LDR's are of 20k ohm.


Correct me if I am wrong but wouldn't connecting inverting and non inverting pins together give us same output at both the ends?? I mean that would be like using only one comparator. We want the outputs to be opposite. If left hand set of the LDR's show more resistance then the corresponding LED should light up and the other switch off.

This is what I think. Correct me if I am wrong.

Thanks for telling me the softwares to draw circuits.

asimov_18
07-09-2010, 07:39 PM
Hi,
where did you get the circuit schematic from? Did you make on your own?

Start the debugging in steps (didvide and conquer). make a test circuit as follows

1) the output stage of the op amp connect a LED with a currect limiting resistor such that the op-amp(comparator) sinks the current(something you have done correctly)
2) start with 2 trimmers/variable resistor . connect the two extreme ends to VCC and GND(possibly include a safty resistor to prevent over heating)
3) connect the wiper of the two trimmer to the inverting and non inverting input of the OP-amp(comparator) .
4) adjust the volatge at one of the trimmer at VCC/2
5) slowly adjust the volatge of the second variable resister and check if the comparator(OP-AMP) works fine.

Asimov

allbits
07-10-2010, 02:13 PM
The circuit is a bit too small. I cant make out much..

Do this and get back -

Connect just the IC (NOTHING ELSE - NO LEDs, NO LDRs Nothing) to the breadboard, and give power to the chip.
See if the voltage drops.

and come back. Rest we'll see then.

chaitanya_cr8
07-10-2010, 09:52 PM
the schematic are from a e-book called Robot Building for Beginners.

I will try what you have said. But what about the circuit that I have posted. Is there anything wrong??

chaitanya_cr8
07-10-2010, 09:57 PM
I did what you said ALLBITS. The voltage does drop from 9V to 1.5V?? What may be the reason? The data sheet doesn't say anything like that. Is it faulty??

allbits
07-11-2010, 10:08 AM
Change the chip.

chaitanya_cr8
07-11-2010, 11:07 AM
Change the chip.

OK. I will change the chips. They were damaged, right.

Thanks a lot for the help!!!