PDA

View Full Version : IC confusion



gshubham96
05-23-2011, 10:06 PM
:confused:Hii,
first of all I have checked the net for their datasheets and did not found any diff, but i think i am wrong .
2. IC M74HC04B1 is I am using instead IC HD74LS04P in the circuit img i have posted.
Please tell me that can use IC M74HC04B1 istead of IC HD74LS04P coz i didnt find one.
OR is there any change in connections for IC M74HC04B1 in the circuit.
Regards,326
shubham Garg
http://gshubham96.my3gb.com/Wireless%20motor%20control%20through%20RF%20circui t_0%20(3).gif

P.S.
datasheet of IC M74HC04B1 https://docs.google.com/leaf?id=0B52FCQhiFb4eYjE4YzIwZWMtMzQ4YS00ZGRmLWJjO DQtMzVmMTZjMDY5YjFl&sort=name&layout=list&num=50

datasheet of IC HD74LS04P http://datasheet.octopart.com/HD74LS04P-Hitachi-datasheet-102962.pdf

allbits
05-24-2011, 08:54 AM
anyways, you have not mentioned the problem you are facing. Did you wire the circuit and check?

gshubham96
05-24-2011, 02:42 PM
i checked the circuit ,
it's not working :( every time i press a button the car moves right

allbits
05-25-2011, 02:38 PM
It has nothing to do with the 7404 variant you use, probably something to do with the wiring.

But, did you try pressing other buttons? give more details of the working. Which buttn did you press - Forward, reverse, right, left?

gshubham96
05-25-2011, 03:01 PM
i tried tp press all the butoons one by one,nothing happened xcept that the robot was truning roght whatever i do.
i also noticed a error in the circuit, according to the datasheet pin14 should be supplied +5V.it's not mentioned i the circuit.:'(