PDA

View Full Version : Arduino Uno Tx led always on



gshubham96
12-08-2011, 01:30 PM
I am unable to upload sketches to my arduino. Error coming is that the board is in use.
recently the mcu of my arduino burnt so i got a new one. the problem is coming henceforth.
My board is arduino uno .
My MCU is atmega 328 w/ arduino duemilanove bootloader.
the chip came with preloaded blink sketch which is working just fine.
also, the tx is always on even when the mcu is not connected to the arduino and it is being powered by external power


attached are the pics of the error and my board.

ERROR


Serial port 'com1' already in use. try quitting any programthat may be using it .

Binary sketch size: 1042 bytes (of a 30720 byte maximum)
processing.app.SerialException: Serial port 'COM1' already in use. Try quiting any programs that may be using it.
at processing.app.Serial.<init>(Serial.java:144)
at processing.app.Serial.<init>(Serial.java:76)
at processing.app.debug.Uploader.flushSerialBuffer(Up loader.java:75)
at processing.app.debug.AvrdudeUploader.uploadViaBoot loader(AvrdudeUploader.java:93)
at processing.app.debug.AvrdudeUploader.uploadUsingPr eferences(AvrdudeUploader.java:56)
at processing.app.Sketch.upload(Sketch.java:1603)
at processing.app.Sketch.exportApplet(Sketch.java:156 8)
at processing.app.Sketch.exportApplet(Sketch.java:152 4)
at processing.app.Editor$DefaultExportHandler.run(Edi tor.java:2293)
at java.lang.Thread.run(Thread.java:619)
processing.app.debug.RunnerException: Serial port 'COM1' already in use. Try quiting any programs that may be using it.
at processing.app.debug.Uploader.flushSerialBuffer(Up loader.java:99)
at processing.app.debug.AvrdudeUploader.uploadViaBoot loader(AvrdudeUploader.java:93)
at processing.app.debug.AvrdudeUploader.uploadUsingPr eferences(AvrdudeUploader.java:56)
at processing.app.Sketch.upload(Sketch.java:1603)
at processing.app.Sketch.exportApplet(Sketch.java:156 8)
at processing.app.Sketch.exportApplet(Sketch.java:152 4)
at processing.app.Editor$DefaultExportHandler.run(Edi tor.java:2293)
at java.lang.Thread.run(Thread.java:619)

gshubham96
12-08-2011, 01:37 PM
359361360353354355356357358362

lolman_returns
12-15-2011, 04:04 AM
Sounds to me like it wasn't just the mcu that got burnt on your arduino board.
Sounds like the ft232RL or one of the capacitors or resistors shorted out as well.

I think getting a new board or making a new board would be the best way to go right now.
Making a basic arduino v1.1 board with max 232 might be a easy and quick. You can make it on a breadboard and test it.

roopakjada
12-15-2011, 09:21 PM
a Uno board is different from the dumelanove. a uno dosent use the FDTI chip the dumelanove uses. it has a different boot loader you will need a mcu with the bootloader for uno