PDA

View Full Version : programmer not responding



hacksgen
02-05-2006, 12:59 AM
hey guys as per my previous post i said that the programmer and atmeag16l are not gertting recognised in winavr ponyprogor avrdude.i used all interfaces such as avrdude , ponyprog parallelport and serial interface and few others but with no success.i checked and double checked all connections but no luck.i dunno hwether its the cable fault or mega16's.


so here i am askin anyone to send me a schematic of their working programmer to program atmega16l with the proper layout and connections.
_______________
hey vikas and rao i did read ur project reports fobo and walter in which u hav
-----------------------------------------------------------------------------------------
used a serial programmer but u havent shown what values u used for the components..so can anyone of u send me that programmer with resistor capacitance ,transistor , diodes values.


btw can anyone tell me how to identify whether wny microcontroller is fried or still in good shape.



also please tell me whether i can use the programmer to programm at89c15.if not ii request anyone of u to send me a simple low cost at89c15 programmer schematic.


thanks

my id is harish_ieee@yahoo.co.in

hacksgen
02-05-2006, 01:02 AM
its urgent as i have to submit my project in a months time.although the sensors and other interfaces are coming fine but without the uC the whole proj becomes useless.so please post me the details as soon as possible



thanks

firebolt_4u
02-05-2006, 05:33 PM
hi
i used the bsd programmer and it works grea 4 me
if u want it google 4 the schematics
it is a parallel port programmer

also i faced similar problem
and hacked my brain for days when i got to know that..my cable was faulty
tr n check the connections
or use a chip tester to check ur ic

i hope it helps

tc
adios

shushil
02-06-2006, 01:49 AM
hi hacksgen

i am using stk200 programmer with winavr.
it works fine.
earlier i also find similar problem,but that was due to wrong connection and loose cables.
plz check ur connection and wires.

check this site may help u
http://www.lancos.com/e2p/avrisp-stk200.gif

i am using this programmer and works fine.

yogi
06-30-2006, 07:04 PM
all troubleshooting tips for avr microcontroller programming using avrdude(bsd programmer) are given in this link

http://booksbybibin.14.forumer.com/viewtopic.php?t=6

firoz
07-06-2006, 10:30 AM
hey yogi.
u got really nie stuff in ur site.but u need to fix the images.non of them are loading.
some articles r very intresting.
thanks.
PS:-please fix image problem
thanks

yogi
07-07-2006, 11:35 AM
i am correcting it now. Give me some links for image uploading sites

docel
07-07-2006, 12:18 PM
Haksgen!!
!. Change your computer-- if it is later than p3, 64bit, AMD or latest Laptop. none of them have conventional ports!!


Hi yogi!
See my last post for image upload site details:
http://roboticsindia.com/modules.php?name=Forums&file=viewtopic&t=1617&p=8317