Page 2 of 2 FirstFirst 12
Results 11 to 13 of 13

Thread: prob in H bridge

  1. #11
    Senior Member T-1000
    Join Date
    Jun 2005
    Location
    bangalore
    Posts
    325

    Default

    I usually use MC33883 for an H-Bridge of Nch Mosfets.
    how much was the current rating..? can yu gimme the application ckt for using it...?

    Is the Pmos getting hot even while bridge is off ?
    no

    Are you using a PNP or NPN bjt to switch On Pmos ?
    npn...

    totem pole using discrete npn and pnp. (simplest and best)
    don have an idea abt thios ckt...
    can yu gimme some link...?

    What is the Vds drop across Pmos when the bridge is On ?
    will try tat and tel ya...
    if u thought u r the only mad person on the planet.......u got serious competition here

  2. #12

    Default

    well i am not sure but , iam expecting that u would be using free wheelig diodes also. if not do usse them and if u r using them ,it might be that ur diode is blown due to some reason try checking them/replacing them.

    asimov

  3. #13
    Senior Member T-1000
    Join Date
    Jun 2005
    Location
    bangalore
    Posts
    325

    Default

    iam expecting that u would be using free wheelig diodes also
    yup,.....
    the mos has one inbuilt.......
    if u thought u r the only mad person on the planet.......u got serious competition here

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •