Results 1 to 4 of 4

Thread: RF Help

  1. #1

    Default RF Help

    Hi Friends

    I am making a remote control to control lights.I am using 2 8051 uc's and Vegakit's RF01 433/315 Mhz module.When I directly connect the TX pin of one Microcontroller to RX pin of Other Microcontroller its working fine but when i connect the RF Module it is not working at all.Plz help me out

  2. #2
    Senior Member T-1000 akshay66's Avatar
    Join Date
    Dec 2008
    Location
    New Delhi
    Posts
    472

    Default

    hi
    have a look at this link:
    http://www.multyremotes.com/four-channel-ASK-remote.htm
    This might help you.

    regards
    Redefine it your way!!!!

  3. #3

    Default

    The link is useful but i was planning to use microcontrollers only.Can u plz tell what should Be BAUD RATE so that the RF Module could function properly.I hav tried at a BAUD RATE of 4800 but its not working.

  4. #4
    Senior Member Android
    Join Date
    Jan 2008
    Location
    KGP
    Posts
    104

    Default

    Most important :

    Outputs of those RF modules gives 3V as logic high and around 0.7V as logic low. Three Volts are not sufficient for microcontroller to recognize logic HIGH. Thus at the output of RF module, use LM339 based non-inverting comparator and then give it to uC.

    You can safely use the baud rate of 2400.
    For every minute that is spent in organizing, one hour is earned !

    http://elecrom.wordpress.com/

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •