Results 1 to 4 of 4

Thread: error uploading arduino

  1. #1

    Default error uploading arduino

    Ok

    I got a serial arduino with max chip. First it didnt work because i got no
    seial port . i tried usb to serial but it didnt work.

    So i got a PCI serial card and now it works.

    So when i tried to upload a code i dont know what happen because power is not stable. The power pin does ot fit properly it get on and off. I dont know if this fluctualtion damaege it.

    So by some reason it didnt upload and give following error.

    avrdude: stk500_getsync(): not in sync: resp=0x00
    avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x51

    I thout it was a random error and go on mdifying it replacing male header with female headers. Then i realize this was happening every time.

    I tried other port other OS no good.

    This error comes even it is not connected. I think this error has to do with that it cant connect the board.But the red led which is PIN13 led blink when going through port menu, uploading middle of uploading etc but with a final blink error comes.

    I tried pressing reset button. It is auto reset because previouly there was know problem.

    So its is boot loader problem , pc problem , board problem( due to heat of soldering iron on removing header

  2. #2
    Senior Member T-1000 debu's Avatar
    Join Date
    Jun 2007
    Location
    New Delhi, India
    Posts
    338

    Default

    @karandex: Didn't you already have a thread to discuss this?

    MAX232 arduino boards work fine with USB to serial adapters. I have an Arduino Pro, which I use with a self made ft232 usb->serial adapter. Just make sure you run the Reset to the RTS pin.

    Regards,

    Debu

  3. #3
    Administrator T-1000 vikas's Avatar
    Join Date
    Feb 2004
    Location
    Delhi
    Posts
    1,922
    Blog Entries
    14

    Default

    Yep please dont repost,better to carry on in the same thread.

    Hard to debug ur board online , Just ask the people who you bought from for a replacement or for fixing it.
    Vikas Patial

  4. #4

    Default

    that thread was about usb to serial

    now i got pci card after working there is new problem

    i think its due to power on-off fluctuation due to adapter . how can erase and put bootloader again

    i am going to order usb board then will see of this serial board

    when Ri shop will open or i will order from bhasha

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •