Results 1 to 8 of 8

Thread: AVRDUDE error - Device not responding

  1. #1
    Senior Member Cyborg devpriya's Avatar
    Join Date
    Jul 2005
    Seattle, WA, USA

    Default AVRDUDE error - Device not responding

    I am trying to program my ATTiny26 using a 4MHz oscillator with 27pF capacitors connect between XLAT1 and XLAT2 pins.

    The other connections are

    LPT ---- uC
    7 Reset
    8 SCK
    9 MOSI
    10 MISO
    18 GND

    whenever i give the command

    avrdude -p t26 -c bsd -U flash:w:tiny26.hex

    i get the error

    Device not responding

    Please help me out , where have i gone wrong?

  2. #2


    I also got this problem too many times

    The main reasons are

    1. u connected reset pin to external Vcc or gnd ( disconnect it)
    2. External power supply may be off
    3. parallel port cable may be not fitted properly
    4. See whether u interchanged MISO and MOSI
    5. see whether ur parallel port is working or not by using LPT.exe

    I never used ATTiny but I used Atmega32 and Atmega8515 with this.
    These are the main solution I have found till now eventhough I got this problems more than 10 times. If you found anything new plz put here.

    Bibin John

  3. #3
    Junior Member User
    Join Date
    Jun 2005
    Belgrade, Serbia


    i had same problem few days ago,
    i retraced some board i was using with it, and i started to think i burnt the uC, what comes out is that cable was faulty, so i built brand new one (with better isolation between pins inside of the SUB25 housing).
    try that, test with a multimeter all 5 wires of the cable
    test from start point (sub25 pins) to end point (pins on connector, then check if there is a connection where there shouldnt be any.

  4. #4
    Senior Member Cyborg devpriya's Avatar
    Join Date
    Jul 2005
    Seattle, WA, USA


    hey Yogi , i tried the same circuit to program my MEGA8515 too but it didnt work there also. I have gone through all of your checklists and i am fulfilling all the required conditions. My parallel port is also working fine which i have checked both input and output using a C program for switching LEDs ON and OFF and i took i input by grounding the pins one by one.

    I have gone through some text on the net and they say that the default programming option for most AVR uCs is that they have to work with the internal clock circuitry, if you want to modify that option then you will have to do high voltage Parallel programming which is quite difficult as it needs too much of connections.

    This is my first programming experience , I am having AT80c2051, AT89S52,
    ATMega8515, ATMega8 and ATTiny26 with me.

    I have tried AVRDUDE, PonyProg, AEC_ISP and AVRISP softwares but all not working.

    I have tried 1MHz, 4,8,10,12,16 MHz oscillators with 22,27,33,39pF capacitors.

    I think I have used all the available options from my side but couldnt get any result. may be some silly thing I am doing wrong, but again going through your checklist I am nowhere wrong. I am having a lot of uCs with me so I can't blame that the uC is not working too.

    My C programs which I have wrote for motion control, robotic arm control they all work fine with the same cable which I use for programming.

    Do I need to change any bits in the 0x37a address , i think the programming softwares take care of that!

    Tell me what to do????

    Please guys help me out!

  5. #5


    don't get discouraged

    check is there any loose connection b/w wires and cable of parallel port

    check the one i said in above

    Now also i have done the programming with avrdude and winavr

    tell which one are u using for programming(avrdude or winavr). Have u installed 'installgiveio'

    Don't get frustrated with these much probs. I am sure that avrdude will work fine. Because the same probs u are having now occured with me too many times. Tell whcih OS ur working (windows or linux).

  6. #6


    Tell abt

    1. operating system u r working
    2. about software u r using

  7. #7
    Senior Member Cyborg devpriya's Avatar
    Join Date
    Jul 2005
    Seattle, WA, USA


    Hey I tried AVRDUDE on both Windows 98 and XP and still i get the same error. On Windows XP i have run installgive_io.bat before using AVRDUDE.

    Tell me which oscillator you guys use and which circuit u have used for your ISP , there are many circuits on the net, so give me the circuit u used Yogi.

    Tell me the values of resistors and capacitors you have used for Mega8 or Mega8515.

    Yaar I am really frustated with this error, I have been into this for past one month and till now not a single uC programmed.

    All the time i have to just simulate my programs in AVR Studio and see its working, I am dying to see it actually work.

    Help me out!

  8. #8


    I have uploaded the picture in the link

    I think the main probs with cable itself. Test ur cable first using simple C program and see whether the wires are proper or so. But I am sure that AVrdude will work.

    Can you get some Winavr or Avrgcc samples or beginner tutorials. I have worked with avrstudio. Now I am trying to do in C

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts