Results 1 to 7 of 7

Thread: ATmega8515 programming problem

  1. #1

    Default ATmega8515 programming problem

    hello all

    i programmed ATmega8515.it works fine.but when i put it out from parallel port ,it didnot work. then i tried to program fuse bits.but now i am not able to even program it as before.it shows avr device is not responding.
    i am using winavr and stk200 programmer. i am not using external oscillator.


    thanks in advance

  2. #2
    Senior Member Android
    Join Date
    Nov 2004
    Posts
    144

    Default

    Your trouble is not clear to me!!

    All I can say....revert back to last working condition and try again.

    Good luck

  3. #3

    Default

    the programmer ckt which i am using is::
    http://www.lancos.com/e2p/avrisp-stk200.gif

  4. #4

    Default

    thanx jack

    my problem in detail is::

    first i made a programmer .then i programmed uc mega8515 with this programmer using winavr.it was succesful.two or three times i overwrite it.Notice that
    i am not using ne external ossccilator.but when I disconnect programmer
    from parallel port,it didn't work.I thought ,this is due to not using osscilator.then I install ponyporg and unsuccessfully tried to program cksel fuse bits.it show device is not connected.then i tried to reprogram into
    uc using winavr ,but this time ,it also shows avr device not responding.
    > "make.exe" program
    avrdude -p atmega8515 -P lpt1 -c stk200 -U flash:w:test_motorsF3.hex

    avrdude: AVR device not responding
    avrdude: initialization failed, rc=-1
    Double check connections and try again, or use -F to override
    this check.


    avrdude done. Thank you.

    make.exe: *** [program] Error 1

    > Process Exit Code: 2

    then i tried to overwrite using dos window,it shows
    avrdude: AVR device not responding
    avrdude: initialization failed, rc=-1
    vr device initialized and ready to accept instructions

    Readibg | ######################### 100% 0.00s

    avrdudeevice signature=0x000000

    avrdude: safemode: Fuses OK

    avrdude done

    Ii am new for uc.Ii donot know how to go back previous working condition.help me

  5. #5

    Default

    I programmed aVR using BSD programmer


    The main probs of avrdude programmer are

    I also got this problem too many times

    The main reasons are

    1. u connected reset pin to external Vcc or gnd ( disconnect it)
    2. External power supply may be off
    3. parallel port cable may be not fitted properly
    4. See whether u interchanged MISO and MOSI
    5. see whether ur parallel port is working or not by using LPT.exe
    6. Check the parallel port chord


    some parallel ports won't work like that of Intel915 bcz they have special protection, i don't know much abt it. I have tried parallel port interfacing on it but data port was not properly working.

    Tell which OS r u using and uC.



    Now the main problems are


    Yikes! :- I have faced it, but after sometime i again programmed it(i might have done some hardware repairs), it worked properly.

    Verification Error:- This is due to loose contact with wires. If u keep wires just touched with parallel port(once i tried with hand for connecting parallel port and wires to uC), then this occured.

    So u check the following things:-

    1. Check breadboard, new breadboards have this problem(some parts don't have good connection)
    2.Check ur parallel port with lpt.exe
    3. See any loose contact.
    4. See the tips i said above

    I think now this will work

    see
    http://www.roboticsindia.com/modules...iewtopic&t=840


    Bibin John
    www.bibinjohn.tk

  6. #6

    Default

    thnx jack and yogi for suggestion.
    actually i read ur article previously also and did all these things,which u mentioned in previous article.
    now got the solution and it works fine.
    the problem was ,a very fine wire which was covered by soldering paste causing short ckt between two pins of programmer ic on pcb.

  7. #7

    Default

    I am a new AVR user.I am having a similar problem.I'll explain
    1)My programmer is STK200 based.I am using LPT1 pins as below
    6=SCk
    7=MOSI
    9=RST
    10=MISO
    2 and 12 shorted
    3 and 11 shorted

    Now I have pony prog as well as Codevision's inbuilt programmer.
    Before flashing this IC i tried reading its flash/eeprom etc and good,it reads.
    Now I am using external xtal 4MHz so
    (in codevision,I checked) CKOPT CKSEL3 2 1 0 SUT1
    I did not touch Boot Lock Bit0 and Bit1 (default setting is B01=B02=1 and
    B11=B12=0)

    Now I hit program flash with a hex file.The mega8515 is programmed,and its flash is verified.I can see the progress bar.

    After this I again try to read the mega8515 but now it cant read the device.
    I therefore put a fresh mega8515 and it is recognised(so no problem with the flasher ckt) but not the already 'fused' mega.
    Have I done anything wrong here
    Please help

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •